Trees

1. Consider the following data type `Tree` and consider an example inhabitant `tree`:

```haskell
data Tree a = Bin (Tree a) a (Tree a) | Leaf deriving Show

tree :: Tree Int
  tree = Bin (Bin (Bin Leaf 1 Leaf) 2 (Bin Leaf 3 Leaf)) 4 (Bin Leaf 5 Leaf)
```

(a) (3 points) Define a higher-order function `foldTree` that corresponds to the fold or catamorphism over our trees using recursion directly. Write down the type of `foldTree`.

**Solution:**

```
foldTree :: (result → a → result → result, result) → Tree a → result
foldTree alg@(bin, leaf) tree =
  case tree of
    Bin l a r → bin (foldTree alg l) a (foldTree alg r)
    Leaf → leaf
```

1 point for the type signature; 1 point per case branch.

(b) (4 points) Use `foldTree` to define the following two functions:

- `height :: Tree a → Int`
- `mapTree :: (a → b) → Tree a → Tree b`

The function `height` should produce the height of a tree, whereas `mapTree` applies a given function to all the elements of a tree. For example, `height tree` gives 3, and `mapTree even tree` returns `Bin (Bin (Bin Leaf False Leaf) True (Bin Leaf False Leaf)) True (Bin Leaf False Leaf)`.

**Solution:**

```
height = foldTree (λl _ r → 1 + max l r, 0)
mapTree f = foldTree (λl a r → Bin l (f a) r, Leaf)
```

2 points per function; 1 point per tuple pair.

(c) (3 points) Define a type `TreeF` that corresponds to the pattern functor representing the `Tree` data type. You may do so by defining a data type directly, or using the pattern functor combinators we have seen in class. Show that this type is indeed a functor by defining its `Functor` instance.

**Solution:**

```
type TreeF a t = BinF t a t | LeafF
```

1 point for the right kind; 1 point per constructor.

(d) (4 points) Use `foldTree` to write a function for collecting the elements of a tree in a depth-first order.

```
depthfirst :: Tree a → [a]
```

For instance, `depthfirst tree` gives `[1, 3, 2, 5, 4]`. Take into account that concatenation of two lists (+) requires a traversal over the left operand – for full points you should prevent quadratic behavior for `depthfirst`. 
Solution:
\[
\text{depthfirst tree } = \\
\text{foldTree } (\lambda f \ a \ g \rightarrow f \circ g \circ (a;), \text{id}) \text{ tree } [ ]
\]
2 points for naive solution. 1 point for using difference lists; 1 point for base case; 2 points for each component of the algebra.

(e) (2 points) A colleague defines the following `Arbitrary` instance for trees:

\[
\text{instance Arbitrary } a \Rightarrow \text{Arbitrary } (\text{Tree } a) \text{ where}
\]

\[
\text{arbitrary } = \text{oneof } [ \text{arbitraryBin}, \text{return Leaf} ]
\]

\[
\text{where}
\]

\[
\text{arbitraryBin } :: \text{Arbitrary } a \Rightarrow \text{Gen } (\text{Tree } a)
\]

\[
\text{arbitraryBin } = \text{do}
\]

\[
t1 \leftarrow \text{arbitrary}
\]

\[
x \leftarrow \text{arbitrary}
\]

\[
t2 \leftarrow \text{arbitrary}
\]

\[
\text{return } (\text{Bin } t1 \ x \ t2)
\]

What problems might you encounter when running tests on random trees generated in this fashion? How can these be fixed?

Solution: It may generate diverge when generating test data. These can be fixed by using combinators such as `sized`.

(f) (6 points) Give the definition and type signature of a function `unfoldTree` corresponding to the unfold or anamorphism for our tree data type. Use `unfoldTree` to write a function `buildTree` (partial) inverse of `depthfirst` using it. Formulate the QuickCheck property relating `depthfirst` and `buildTree` that you expect to hold.

Solution:

\[
\text{unfoldTree } :: (s \rightarrow \text{Maybe } (s, a, s)) \rightarrow s \rightarrow \text{Tree } a
\]

\[
\text{unfoldTree coalg seed } = \text{case coalg seed of}
\]

\[
\text{Nothing } \rightarrow \text{Leaf}
\]

\[
\text{Just } (l, x, r) \rightarrow \text{Bin } (\text{unfoldTree coalg } l) \ x \ (\text{unfoldTree coalg } r)
\]

\[
\text{buildTree } :: [a] \rightarrow \text{Tree } a
\]

\[
\text{buildTree } = \text{unfoldTree step}
\]

\[
\text{where}
\]

\[
\text{step } [ ] = \text{Nothing}
\]

\[
\text{step } (x : xs) = \text{Just } ([], x, xs)
\]

\[
\text{buildTreeProp } :: \text{Int} \rightarrow \text{Bool}
\]

\[
\text{buildTreeProp } xs = \text{depthfirst } (\text{buildTree } xs) \equiv xs
\]

1 point for type signature; 1 point per branch; 2 point for `buildTree`; 1 point for property.

(g) (2 points) Using `unfoldTree` it becomes possible to computations returning `infinite` data structures. Use `unfoldTree` to define an infinitely deep tree `natTree`, where every node is labeled with its depth: the root is labelled 0; its children are labelled 1; the root’s grandchildren are labelled 2; etc.

Solution:

\[
\text{natTree } :: \text{Tree } \text{Int}
\]

\[
\text{natTree } = \text{unfoldTree coalg } 0
\]

\[
\text{where}
\]

\[
\text{coalg } n = \text{Just } (n + 1, n, n + 1)
\]
(h) (4 points) A colleague claims that the definition of \textit{natTree} relies on Haskell's lazy evaluation. Explain how – inspired by work on data fusion – infinite data structures can even be represented in \textit{strict} programming languages.

\textbf{Solution:} We can represent an infinite data type by the coalgebra generating it – this is what data fusion techniques do. The resulting definitions are no longer recursive and therefore no longer rely on lazy evaluation.

\section*{Success}

2. With the data type \textit{Step} we can encode certain search problems. At every point in the search space, we can return success, failure, or choice of steps that may themselves fail or succeed:

\textbf{data} \textit{Step a} = \textit{Success a} | \textit{Fail} | \textit{Steps} [\textit{Step a}]

(a) (4 points) Make \textit{Step} an instance of the \textit{Functor} and \textit{Foldable} type classes. These are declared as follows:

\begin{verbatim}
class Functor f where
  fmap :: (a -> b) -> f a -> f b

class Foldable f where
  foldMap :: Monoid m => (a -> m) -> f a -> m
\end{verbatim}

\textbf{Solution:} instance \textit{Functor} \textit{Step} where \textit{fmap} \textit{f} \textit{Fail} = \textit{Fail} \textit{fmap} \textit{f} (\textit{Success} \textit{a}) = \textit{Success} (\textit{f} \textit{a}) \textit{fmap} \textit{f} (\textit{Steps} \textit{steps}) = \textit{Steps} (\textit{map} (\textit{fmap} \textit{f}) \textit{steps})

instance \textit{Foldable} \textit{Step} where \textit{foldMap} \textit{f} \textit{Fail} = \textit{mempty} \textit{foldMap} \textit{f} (\textit{Success} \textit{x}) = \textit{f} \textit{x} \textit{foldMap} \textit{f} (\textit{Steps} \textit{steps}) = \textit{foldr} \textit{mempty} \textit{mappend} (\textit{map} (\textit{foldMap} \textit{f}) \textit{steps})

(b) (3 points) Show how to use the \textit{foldMap} function to define a function \textit{collect}, that computes a list with all the \textit{Success} values in a \textit{Step} data structure.

\textbf{Solution:}

\begin{verbatim}
collect :: Step a -> [a]
collect = foldMap (\lambda x -> [x])
\end{verbatim}

(c) (4 points) Write the monadic \textit{join} function for the \textit{Step} data type:

\textit{join} :: \textit{Step} (\textit{Step} a) -> \textit{Step} a

\textbf{Solution:} \textit{join} :: \textit{Step} (\textit{Step} a) \rightarrow \textit{Step} a = \textit{Steps} (\textit{map} \textit{join} \textit{steps})

(d) (4 points) Give an instance definition for the \textit{Step} data type for the \textit{Monad} type class. Your instance declaration should respect the three monad laws (but you don’t have to prove this).

\textbf{Solution:}

\begin{verbatim}
instance Monad \textit{Steps} where
  return \textit{x} = \textit{Success} \textit{x}
  \textit{Fail} >>= \textit{f} = \textit{Fail}
  \textit{Success} \textit{x} >>= \textit{f} = \textit{f} \textit{x}
  \textit{Steps} \textit{steps} >>= \textit{f} = \textit{Steps} (\textit{map} (\lambda \textit{step} \rightarrow \textit{step} >>= \textit{f}) \textit{steps})
\end{verbatim}
(e) (4 points) With Step being a Monad, we can now use Haskell’s do notation:

```haskell
m :: Step (Int, Int)
m = do a ← Success 1
     b ← Steps [Fail, Success 2]
     return (a, b)
```

Give the value of \( m \) in terms of the three constructors of \( \text{Step} \).

**Solution:** Steps [Fail, Success (1,2)]

(f) (6 points) The following law should hold for the Step monad:

\[
\text{fmap } f \circ \text{fmap } g \equiv \text{fmap } (f \circ g)
\]

Prove that the instance declaration you provided for (a) respects this law. (If the law does not hold, your instance definition is probably wrong). If you rely on any auxiliary lemmas, these should be stated explicitly.

**Solution:** Do induction over \( \text{Steps} \):

- The case for \( \text{Fail} \) we have:

\[
\text{fmap } f (\text{fmap } g \text{ Fail}) \\
\equiv \\
fmap f \text{ Fail} \\
\equiv \\
\text{Fail} \\
\equiv \\
fmap (f \circ g) \text{ Fail}
\]

- The case for \( \text{Success} \) we have:

\[
\text{fmap } f (\text{fmap } g \text{ Success } x)) \\
\equiv \\
fmap f \text{ Success } (g x) \\
\equiv \\
\text{Success } (f \text{ (g x))} \\
\equiv \\
fmap (f \circ g) \text{ (Success } x) \\
\]

- The case for \( \text{Steps} \):

\[
\text{fmap } f (\text{fmap } g \text{ (Steps steps)}) \\
\equiv \\
fmap f \text{ (Steps (map (fmap } g \text{ steps))} \\
\equiv \\
\text{Steps (map (fmap } f \text{ (map (fmap } g \text{ steps}))} \\
\equiv \\
\text{Steps (map (fmap } (f \circ g) \text{ steps))} \\
\equiv \\
fmap (f \circ g) \text{ (Steps steps)}
\]

**Printf**

3. In this question, you will show how to use GADTs to define a well-typed printf function. The printf function is typically used for debugging. The first argument is a string. This string is printed to stdout. If the string contains special formatting directives, the call to printf requires additional arguments. For
the purpose of this exercise, we will assume two formatting directives \%d and \%s. Here are some example
invocations of printf:

```c
printf("Hello world\n");
// Prints: Hello world
printf("Hello there \%s", "Wouter");
// Prints: Hello there Wouter
printf("\%s = \%d", "x", 5);
// Prints: x = 5
```

Instead of taking a string as its first argument, however, we will use (a variation of) the following data
type to represent our formatting directives:

```
data Format where
    Lit :: String → Format → Format -- Print a literal string fragment and continue
    D :: Format → Format              -- Require an integer input
    S :: Format → Format              -- Require a string input
    Done :: Format                    -- No further directives
```

(a) (3 points) Show how the formatting strings from the three examples above can all be represented
as values of type Format.

Solution:

- Lit "Hello World" Done
- Lit "Hello there " (S Done)
- S (Lit " = " (D Done))

(b) (4 points) The Format data type is a simple algebraic data type. Define a GADT Format’ a that
takes a single type argument. The three examples above should have the following types:

- Format’ String
- Format’ (String → String)
- Format’ (String → Int → String)

A formatting directive of type Format’ a requires additional arguments specified by the type a.
Ensure that your answers from part (a) give rise to a Format’ data type of the correct type.

Solution:

```
data Format a where
    Done :: Format String
    Lit :: String → Format a → Format a
    D :: Format a → Format (Int → a)
    S :: Format a → Format (String → a)
```

(c) (6 points) Define a function format :: Format’ a → a that behaves like the printf function described
above. You may find it useful to define this function using an auxiliary function:

`format’ :: Format’ a → String → a`

which is defined using an accumulating parameter.
Solution:

```haskell
format :: Format a → a
format f = format' f ""

where
  format' :: Format a → String → a
  format' (Done) s = s
  format' (Lit str f) s = format' f (s ++ str)
  format' (D f) s = λd → format' f (s ++ show d)
  format' (S f) s = λs' → format' f (s ++ s')
```

(d) (4 points) To provide exactly the same interface as printf, a fellow student proposes to define an auxiliary function:

```haskell
toFormat' :: String → Format' a
```

that parses the String argument and recognizes any formatting directives. What will go wrong when trying to define the toFormat function? How might you be able to fix this?

Solution: The above type signature is too general. It guarantees to return a Format' a for all a. It needs to be hidden or existentially quantified rather than universally quantified.
SKI – Take home

4. Please submit your solution no later than midnight on Friday April 14th via submit.

Ulf Norell’s Agda tutorial defines a data type for the well-typed, well-scoped lambda terms:

```agda
data Term (Γ : Ctx) : Type → Set where
  var : τ ∈ Γ → Term Γ τ
  app : Term Γ (σ ⇒ τ) → Term Γ σ → Term Γ τ
  lam : Term (σ :: Γ) τ → Term Γ τ
```

In the lectures, we saw how to define a simple evaluator for such lambda terms.

```agda
Val : Type → Set
Val i = Unit
Val (σ ⇒ τ) = Val σ → Val τ
eval : Term Γ σ → Env Γ → Val σ
```

In this exercise you will define a translation from these lambda terms to SKI combinators and try to prove it correct. You may find it useful to consult background material on combinatory logic to help understand the translation from lambda terms to SKI combinators.

To define this translation, you will need to define several intermediate steps:

(a) (4 points) Define a data type for well-typed combinator terms. This data type should be able to represent:
   • the atomic combinators $S$, $K$, and $I$;
   • the application of one combinator term to another;
   • variables drawn from some context.

   Crucially, this term language should not include a constructor for lambdas. Be careful to choose your datatype so that it can only represent well-typed SKI terms. You may want to use ghci to check the types of the three atomic combinators for you.

(b) (4 points) Define an interpretation function, $evalSKI$, that given an SKI term of type $σ$ and a suitable environment, produces a value of type $Val σ$.

(c) (6 points) Define a translation from lambda terms, $Term Γ σ$, to your SKI data type. Hint: define an auxiliary function $lambda$ to handle the case for abstractions $lam$. What is the type of $lambda$?

(d) (6 points) Formulate the property that your translation is correct and prove that this is the case for applications and variables. What goes wrong when you try to prove the branch for lambda abstractions? What property can you formulate and prove that relates $evalSKI$ and the auxiliary $lambda$ that you defined above?